Posts Tagged ‘Switch’

Meraki MX Router

Enable Vlans

Go to Security Appliance then Addressing & VLANs

Next setup the Subnet ID ( Number ) for your Vlans and the Address of the Router in each Vlan 

Next Change the Uplink to the Switch to a VLAN and set the Native Vlan ( this is the default usually 1 ) and the other Vlans which will pass down this trunk. The Native VLAN will need to be the same on both sides of Meraki and Cisco Switch

DHCP

Go to Security Appliance then DHCP

What device will be the DHCP on this new Subnet? You can set the Meraki or if its a Windows Network point the IP Helper to your main DHCP server

Cisco Switch

Uplink

On the uplink of your switch to the Meraki set e.g. GigabitEthernet1/0/1

 

conf t
int gi1/0/1
switchport trunk native vlan 1
switchport trunk allowed vlan 1,5
switchport mode trunk
end

You might see the native vlan 1 not showing in the config , this is because 1 is always the native vlan

UnTag Port on new Vlan

This changes the port to use Vlan 5

conf t
int gi1/0/2
switchport acccess vlan 5
switchport mode access
end
VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)

Configuration:

Disable DCB:

enable
configure
no dcb enable
exit

Configure out of band management port:

enable
configure
interface out-of-band
ip address X.X.X.X /24 192.168.1.1
exit

Http and telnet authentication:

enable
config
line telnet
login authentication default
exit
ip http authentication local

SSH keygen and enable

configure
crypto key generate rsa
crypto key generate dsa
ip ssh server

Configure login credentials:

username admin password yourpassword privilege 15
enable password yourpassword

Enable iSCSI optimization feature:

configure
iscsi enable
Are you sure you want to continue? y
exit

Configure flow control:

configure
flowcontrol
Are you sure you want to continue? y

Configure Jumbo MTU for all ports:

configure
system jumbo mtu 9216
exit

Configure spanning tree portfast on edge ports:

configure
interface range tengigabitethernet all
spanning-tree portfast
exit

Configure QSFP ports for LAG:

interface range yourports
no spanning-tree portfast
channel-group 1 mode active
exit

Save Configuration:

copy running-config startup-config

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)

Get the port number on the switch , if you stack you should get the switch number as well

You can use show int to list all the interfaces , get the switch port value e.g. gi/1/0.8

Use sh int gi1/0/8 to list the port details to make sure its up etc

Next run :

show mac address-table int gi1/0/8

( copy the address it gives you Address )

Next Run this

show arp | incl %macaddressofabove%

If it doesn’t show anything the device might not have an IP ( check port is on correct Vlan )

** A cheat , on a computer connected to the switch on the same Vlan and IP range , you can manually add an IP to the mac address then try and ping/access the device :

In Windows Xp

arp -s %spareip% %macAddress%

In Windows 7

netsh -c interface ipv4 add neighbors “Network Card Name” “IP Address” “MAC Address”
VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)