Citrix HDX Optimization – Teams Audio/Video failing to work on Session disconnect/reconnect

There are a couple of key active known issue about HDX Optimization failing in certain situations, the above included, as of May 2020.

https://support.citrix.com/article/CTX253754

  • In Windows Server (any version, with any VDA 1906.2 or higher), session disconnect/reconnect might result in Teams failing to load in optimized mode (“Citrix HDX Not Connected” in About/Version). Citrix and Microsoft are aware of this issue and are rolling out the fix, deployed already in Ring 3. This will not require any component upgrade (Teams, VDA or Workspace app) and is rolled out via feature flags (sign out/sign in required). In some scenarios, attempting to make a call will trigger Teams to try to reconnect to the Citrix services and optimization will succeed. [RFWIN-15624] [Microsoft Teams Bug ID: 873138]
  • If Teams is configured to Auto-start, the issue in the first [above] bullet might also manifest. We recommend disabling auto-start by deleting the Teams regkeys in HKLM\Software\Microsoft\Windows\CurrentVersion\Run, HKLM\Software\WOW6432Node\Microsoft\Windows\CurrentVersion\Run and HKCU\Software\Microsoft\Windows\CurrentVersion\Run

  • Endpoints with high-end sound cards (Studio quality) might fail to load in optimized mode. See section #2.1 below. Clicking on Teams/Settings/Devices will show “None”. Citrix is aware of this issue and working on a fix. [RFWIN-17892]

It does go on to say “that, generally, fully quitting Teams (Systray icon / right click / quit) and restarting it clears all the components involved and can fix whatever issue you were experiencing.”

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)

Tags: Citrix, connect, disconnect, HDX Optimization, reconnect, Teams

Trackback from your site.