{"id":9501,"date":"2026-03-23T23:17:49","date_gmt":"2026-03-23T23:17:49","guid":{"rendered":"https:\/\/pariswells.com\/blog\/?p=9501"},"modified":"2026-03-25T21:58:32","modified_gmt":"2026-03-25T21:58:32","slug":"excessive-number-of-failed-connections-from-127-0-0-1-2","status":"publish","type":"post","link":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2","title":{"rendered":"Excessive number of failed connections from 127.0.0.1"},"content":{"rendered":"\n<p class=\"wp-block-paragraph\">This Senitel Rule wasn&#8217;t the clearest with what was causing these<\/p>\n\n\n\n<p class=\"wp-block-paragraph\">I updated the rule to the below and also whitelisted some false positives <\/p>\n\n\n\n<pre class=\"wp-block-code\"><code class=\"\">DeviceNetworkEvents\n| where ActionType == \"ConnectionFailed\"\n\/\/ Rename LocalIP to SrcIpAddr early so it flows through to final output\n| extend SrcIpAddr = LocalIP\n| summarize Count = count() by \n    DeviceName,\n    DeviceId,\n    SrcIpAddr,\n    InitiatingProcessFileName,\n    InitiatingProcessCommandLine,\n    bin(Timestamp, 5m)\n| where Count > 100\n| summarize \n    TotalCount = sum(Count),\n    FirstSeen = min(Timestamp),\n    LastSeen = max(Timestamp)\n    by\n    DeviceName,\n    DeviceId,\n    SrcIpAddr,\n    InitiatingProcessFileName,\n    InitiatingProcessCommandLine\n| extend threshold = 5000\n| order by TotalCount desc<\/code><\/pre>\n\n\n\n<p class=\"wp-block-paragraph\">## Then Fix the Wizard Settings **Entity Mapping:** | Field | Value | |&#8212;|&#8212;| | Entity type | IP | | Identifier | Address | | Column | `SrcIpAddr` ? | **Custom Details:** | Key | Value | |&#8212;|&#8212;| | NumberOfDenies | `TotalCount` ? | **Alert Name Format:** &#8220;` Excessive number of failed connections from {{SrcIpAddr}} &#8220;` **Alert Description Format:** &#8220;` The client at address {{SrcIpAddr}} generated more than {{threshold}} failures over a 5 minutes time window, which may indicate malicious activity.<\/p>\n","protected":false},"excerpt":{"rendered":"<p>This Senitel Rule wasn&#8217;t the clearest with what was causing these I updated the rule to the below and also whitelisted some false positives ## Then Fix [&hellip;]<\/p>\n","protected":false},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[1],"tags":[],"class_list":["post-9501","post","type-post","status-publish","format-standard","hentry","category-research"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 4.9.9 - aioseo.com -->\n\t<meta name=\"description\" content=\"This Senitel Rule wasn&#039;t the clearest with what was causing these I updated the rule to the below and also whitelisted some false positives DeviceNetworkEvents | where ActionType == &quot;ConnectionFailed&quot; \/\/ Rename LocalIP to SrcIpAddr early so it flows through to final output | extend SrcIpAddr = LocalIP | summarize Count = count() by DeviceName,\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"paris\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2\" \/>\n\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 4.9.9\" \/>\n\t\t<meta property=\"og:locale\" content=\"en_US\" \/>\n\t\t<meta property=\"og:site_name\" content=\"Welcome to Pariswells.com |\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"Excessive number of failed connections from 127.0.0.1 | Welcome to Pariswells.com\" \/>\n\t\t<meta property=\"og:description\" content=\"This Senitel Rule wasn&#039;t the clearest with what was causing these I updated the rule to the below and also whitelisted some false positives DeviceNetworkEvents | where ActionType == &quot;ConnectionFailed&quot; \/\/ Rename LocalIP to SrcIpAddr early so it flows through to final output | extend SrcIpAddr = LocalIP | summarize Count = count() by DeviceName,\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2026-03-23T23:17:49+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2026-03-25T21:58:32+00:00\" \/>\n\t\t<meta name=\"twitter:card\" content=\"summary\" \/>\n\t\t<meta name=\"twitter:title\" content=\"Excessive number of failed connections from 127.0.0.1 | Welcome to Pariswells.com\" \/>\n\t\t<meta name=\"twitter:description\" content=\"This Senitel Rule wasn&#039;t the clearest with what was causing these I updated the rule to the below and also whitelisted some false positives DeviceNetworkEvents | where ActionType == &quot;ConnectionFailed&quot; \/\/ Rename LocalIP to SrcIpAddr early so it flows through to final output | extend SrcIpAddr = LocalIP | summarize Count = count() by DeviceName,\" \/>\n\t\t<script type=\"application\/ld+json\" class=\"aioseo-schema\">\n\t\t\t{\"@context\":\"https:\\\/\\\/schema.org\",\"@graph\":[{\"@type\":\"Article\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/excessive-number-of-failed-connections-from-127-0-0-1-2#article\",\"name\":\"Excessive number of failed connections from 127.0.0.1 | Welcome to Pariswells.com\",\"headline\":\"Excessive number of failed connections from 127.0.0.1\",\"author\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris#author\"},\"publisher\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#organization\"},\"datePublished\":\"2026-03-23T23:17:49+00:00\",\"dateModified\":\"2026-03-25T21:58:32+00:00\",\"inLanguage\":\"en-US\",\"mainEntityOfPage\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/excessive-number-of-failed-connections-from-127-0-0-1-2#webpage\"},\"isPartOf\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/excessive-number-of-failed-connections-from-127-0-0-1-2#webpage\"},\"articleSection\":\"Research\"},{\"@type\":\"BreadcrumbList\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/excessive-number-of-failed-connections-from-127-0-0-1-2#breadcrumblist\",\"itemListElement\":[{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog#listItem\",\"position\":1,\"name\":\"Home\",\"item\":\"https:\\\/\\\/pariswells.com\\\/blog\",\"nextItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/category\\\/research#listItem\",\"name\":\"Research\"}},{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/category\\\/research#listItem\",\"position\":2,\"name\":\"Research\",\"item\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/category\\\/research\",\"nextItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/excessive-number-of-failed-connections-from-127-0-0-1-2#listItem\",\"name\":\"Excessive number of failed connections from 127.0.0.1\"},\"previousItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog#listItem\",\"name\":\"Home\"}},{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/excessive-number-of-failed-connections-from-127-0-0-1-2#listItem\",\"position\":3,\"name\":\"Excessive number of failed connections from 127.0.0.1\",\"previousItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/category\\\/research#listItem\",\"name\":\"Research\"}}]},{\"@type\":\"Organization\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#organization\",\"name\":\"Welcome to Pariswells.com\",\"url\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/\"},{\"@type\":\"Person\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris#author\",\"url\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris\",\"name\":\"paris\",\"image\":{\"@type\":\"ImageObject\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/excessive-number-of-failed-connections-from-127-0-0-1-2#authorImage\",\"url\":\"https:\\\/\\\/secure.gravatar.com\\\/avatar\\\/93b8ee3f592ac401167f870452bd82d43de80152cd3524e2853403658ada9984?s=96&d=mm&r=g\",\"width\":96,\"height\":96,\"caption\":\"paris\"}},{\"@type\":\"WebPage\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/excessive-number-of-failed-connections-from-127-0-0-1-2#webpage\",\"url\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/excessive-number-of-failed-connections-from-127-0-0-1-2\",\"name\":\"Excessive number of failed connections from 127.0.0.1 | Welcome to Pariswells.com\",\"description\":\"This Senitel Rule wasn't the clearest with what was causing these I updated the rule to the below and also whitelisted some false positives DeviceNetworkEvents | where ActionType == \\\"ConnectionFailed\\\" \\\/\\\/ Rename LocalIP to SrcIpAddr early so it flows through to final output | extend SrcIpAddr = LocalIP | summarize Count = count() by DeviceName,\",\"inLanguage\":\"en-US\",\"isPartOf\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#website\"},\"breadcrumb\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/excessive-number-of-failed-connections-from-127-0-0-1-2#breadcrumblist\"},\"author\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris#author\"},\"creator\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris#author\"},\"datePublished\":\"2026-03-23T23:17:49+00:00\",\"dateModified\":\"2026-03-25T21:58:32+00:00\"},{\"@type\":\"WebSite\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#website\",\"url\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/\",\"name\":\"Welcome to Pariswells.com\",\"inLanguage\":\"en-US\",\"publisher\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#organization\"}}]}\n\t\t<\/script>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"Excessive number of failed connections from 127.0.0.1 | Welcome to Pariswells.com","description":"This Senitel Rule wasn't the clearest with what was causing these I updated the rule to the below and also whitelisted some false positives DeviceNetworkEvents | where ActionType == \"ConnectionFailed\" \/\/ Rename LocalIP to SrcIpAddr early so it flows through to final output | extend SrcIpAddr = LocalIP | summarize Count = count() by DeviceName,","canonical_url":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":{"@context":"https:\/\/schema.org","@graph":[{"@type":"Article","@id":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2#article","name":"Excessive number of failed connections from 127.0.0.1 | Welcome to Pariswells.com","headline":"Excessive number of failed connections from 127.0.0.1","author":{"@id":"https:\/\/pariswells.com\/blog\/author\/paris#author"},"publisher":{"@id":"https:\/\/pariswells.com\/blog\/#organization"},"datePublished":"2026-03-23T23:17:49+00:00","dateModified":"2026-03-25T21:58:32+00:00","inLanguage":"en-US","mainEntityOfPage":{"@id":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2#webpage"},"isPartOf":{"@id":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2#webpage"},"articleSection":"Research"},{"@type":"BreadcrumbList","@id":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog#listItem","position":1,"name":"Home","item":"https:\/\/pariswells.com\/blog","nextItem":{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/category\/research#listItem","name":"Research"}},{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/category\/research#listItem","position":2,"name":"Research","item":"https:\/\/pariswells.com\/blog\/category\/research","nextItem":{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2#listItem","name":"Excessive number of failed connections from 127.0.0.1"},"previousItem":{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog#listItem","name":"Home"}},{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2#listItem","position":3,"name":"Excessive number of failed connections from 127.0.0.1","previousItem":{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/category\/research#listItem","name":"Research"}}]},{"@type":"Organization","@id":"https:\/\/pariswells.com\/blog\/#organization","name":"Welcome to Pariswells.com","url":"https:\/\/pariswells.com\/blog\/"},{"@type":"Person","@id":"https:\/\/pariswells.com\/blog\/author\/paris#author","url":"https:\/\/pariswells.com\/blog\/author\/paris","name":"paris","image":{"@type":"ImageObject","@id":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2#authorImage","url":"https:\/\/secure.gravatar.com\/avatar\/93b8ee3f592ac401167f870452bd82d43de80152cd3524e2853403658ada9984?s=96&d=mm&r=g","width":96,"height":96,"caption":"paris"}},{"@type":"WebPage","@id":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2#webpage","url":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2","name":"Excessive number of failed connections from 127.0.0.1 | Welcome to Pariswells.com","description":"This Senitel Rule wasn't the clearest with what was causing these I updated the rule to the below and also whitelisted some false positives DeviceNetworkEvents | where ActionType == \"ConnectionFailed\" \/\/ Rename LocalIP to SrcIpAddr early so it flows through to final output | extend SrcIpAddr = LocalIP | summarize Count = count() by DeviceName,","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/pariswells.com\/blog\/#website"},"breadcrumb":{"@id":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2#breadcrumblist"},"author":{"@id":"https:\/\/pariswells.com\/blog\/author\/paris#author"},"creator":{"@id":"https:\/\/pariswells.com\/blog\/author\/paris#author"},"datePublished":"2026-03-23T23:17:49+00:00","dateModified":"2026-03-25T21:58:32+00:00"},{"@type":"WebSite","@id":"https:\/\/pariswells.com\/blog\/#website","url":"https:\/\/pariswells.com\/blog\/","name":"Welcome to Pariswells.com","inLanguage":"en-US","publisher":{"@id":"https:\/\/pariswells.com\/blog\/#organization"}}]},"og:locale":"en_US","og:site_name":"Welcome to Pariswells.com |","og:type":"article","og:title":"Excessive number of failed connections from 127.0.0.1 | Welcome to Pariswells.com","og:description":"This Senitel Rule wasn't the clearest with what was causing these I updated the rule to the below and also whitelisted some false positives DeviceNetworkEvents | where ActionType == &quot;ConnectionFailed&quot; \/\/ Rename LocalIP to SrcIpAddr early so it flows through to final output | extend SrcIpAddr = LocalIP | summarize Count = count() by DeviceName,","og:url":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2","article:published_time":"2026-03-23T23:17:49+00:00","article:modified_time":"2026-03-25T21:58:32+00:00","twitter:card":"summary","twitter:title":"Excessive number of failed connections from 127.0.0.1 | Welcome to Pariswells.com","twitter:description":"This Senitel Rule wasn't the clearest with what was causing these I updated the rule to the below and also whitelisted some false positives DeviceNetworkEvents | where ActionType == &quot;ConnectionFailed&quot; \/\/ Rename LocalIP to SrcIpAddr early so it flows through to final output | extend SrcIpAddr = LocalIP | summarize Count = count() by DeviceName,"},"aioseo_meta_data":{"post_id":"9501","title":null,"description":null,"keywords":null,"keyphrases":{"focus":{"keyphrase":"","score":0,"analysis":{"keyphraseInTitle":{"score":0,"maxScore":9,"error":1}}},"additional":[]},"canonical_url":null,"og_title":null,"og_description":null,"og_object_type":"default","og_image_type":"default","og_image_url":null,"og_image_width":null,"og_image_height":null,"og_image_custom_url":null,"og_image_custom_fields":null,"og_video":"","og_custom_url":null,"og_article_section":null,"og_article_tags":null,"twitter_use_og":false,"twitter_card":"default","twitter_image_type":"default","twitter_image_url":null,"twitter_image_custom_url":null,"twitter_image_custom_fields":null,"twitter_title":null,"twitter_description":null,"schema":{"blockGraphs":[],"customGraphs":[],"default":{"data":{"Article":[],"Course":[],"Dataset":[],"FAQPage":[],"Movie":[],"Person":[],"Product":[],"ProductReview":[],"Car":[],"Recipe":[],"Service":[],"SoftwareApplication":[],"WebPage":[]},"graphName":"Article","isEnabled":true},"graphs":[]},"schema_type":"default","schema_type_options":null,"pillar_content":false,"robots_default":true,"robots_noindex":false,"robots_noarchive":false,"robots_nosnippet":false,"robots_nofollow":false,"robots_noimageindex":false,"robots_noodp":false,"robots_notranslate":false,"robots_max_snippet":"-1","robots_max_videopreview":"-1","robots_max_imagepreview":"large","priority":null,"frequency":"default","location":null,"local_seo":null,"breadcrumb_settings":null,"limit_modified_date":false,"ai":{"faqs":[],"keyPoints":[],"titles":[],"descriptions":[],"socialPosts":{"email":[],"linkedin":[],"twitter":[],"facebook":[],"instagram":[]}},"created":"2026-03-23 23:15:30","updated":"2026-03-24 02:50:58","primary_term":null,"seo_analyzer_scan_date":null},"aioseo_breadcrumb":"<div class=\"aioseo-breadcrumbs\"><span class=\"aioseo-breadcrumb\">\n\t\t\t<a href=\"https:\/\/pariswells.com\/blog\" title=\"Home\">Home<\/a>\n\t\t<\/span><span class=\"aioseo-breadcrumb-separator\">&raquo;<\/span><span class=\"aioseo-breadcrumb\">\n\t\t\t<a href=\"https:\/\/pariswells.com\/blog\/category\/research\" title=\"Research\">Research<\/a>\n\t\t<\/span><span class=\"aioseo-breadcrumb-separator\">&raquo;<\/span><span class=\"aioseo-breadcrumb\">\n\t\t\tExcessive number of failed connections from 127.0.0.1\n\t\t<\/span><\/div>","aioseo_breadcrumb_json":[{"label":"Home","link":"https:\/\/pariswells.com\/blog"},{"label":"Research","link":"https:\/\/pariswells.com\/blog\/category\/research"},{"label":"Excessive number of failed connections from 127.0.0.1","link":"https:\/\/pariswells.com\/blog\/research\/excessive-number-of-failed-connections-from-127-0-0-1-2"}],"_links":{"self":[{"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/posts\/9501","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/comments?post=9501"}],"version-history":[{"count":3,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/posts\/9501\/revisions"}],"predecessor-version":[{"id":9505,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/posts\/9501\/revisions\/9505"}],"wp:attachment":[{"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/media?parent=9501"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/categories?post=9501"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/tags?post=9501"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}