{"id":9398,"date":"2025-12-03T22:44:23","date_gmt":"2025-12-03T22:44:23","guid":{"rendered":"https:\/\/pariswells.com\/blog\/?p=9398"},"modified":"2025-12-03T23:23:45","modified_gmt":"2025-12-03T23:23:45","slug":"advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender","status":"publish","type":"post","link":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender","title":{"rendered":"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender"},"content":{"rendered":"\n<pre class=\"wp-block-code\"><code class=\"\">\/\/ Non-onboarded\/discovered devices + who saw them + network details + IPs\nDeviceInfo\n| where Timestamp > ago(30d)\n| where OnboardingStatus != \"Onboarded\"               \/\/ all not onboarded\/discovered\n| where isempty(MergedToDeviceId)                    \/\/ Remove invalidated\/merged devices\n| summarize arg_max(Timestamp, *) by DeviceId\n| invoke SeenBy()                                    \/\/ Add detecting onboarded devices\n| join kind=leftouter (\n    DeviceNetworkInfo\n    | where Timestamp > ago(30d)\n    | summarize arg_max(Timestamp, *) by DeviceId    \/\/ Latest network info\n) on DeviceId\n| extend ConnectedNetworksParsed = parse_json(ConnectedNetworks)\n| extend IPAddressesParsed = parse_json(IPAddresses)\n| summarize \n    IPsSeen              = make_set(IPAddressesParsed.Address),\n    DetectingDevices     = make_set(SeenBy),         \/\/ Onboarded devices that saw it\n    NetworkNames         = make_set(ConnectedNetworksParsed.Name),      \/\/ e.g., WiFi SSID or network name\n    NetworkCategories    = make_set(ConnectedNetworksParsed.Category),  \/\/ e.g., Enterprise, Public\n    LastSeen             = max(Timestamp),\n    FirstSeen            = min(Timestamp)\n    by NonOnboardedName = DeviceName, OSPlatform, DeviceId\n| project-reorder NonOnboardedName, IPsSeen, DetectingDevices, NetworkNames, NetworkCategories, OSPlatform, LastSeen, FirstSeen\n| order by LastSeen desc<\/code><\/pre>\n\n\n\n<p class=\"wp-block-paragraph\">Cleaner Version<\/p>\n\n\n\n<pre class=\"wp-block-code\"><code class=\"\">\/\/ Non-onboarded\/discovered devices + who saw them + network details + IPs (excluding Unknown OS, iOS, Android, Linux; remove with no detecting devices)\nDeviceInfo\n| where Timestamp > ago(30d)\n| where OnboardingStatus != \"Onboarded\"               \/\/ all not onboarded\/discovered\n| where isempty(MergedToDeviceId)                    \/\/ Remove invalidated\/merged devices\n| summarize arg_max(Timestamp, *) by DeviceId\n| where isnotempty(OSPlatform) and OSPlatform != \"Unknown\" and OSPlatform !in (\"iOS\", \"Android\", \"Linux\")\n| invoke SeenBy()                                    \/\/ Add detecting onboarded devices\n| join kind=leftouter (\n    DeviceNetworkInfo\n    | where Timestamp > ago(30d)\n    | summarize arg_max(Timestamp, *) by DeviceId    \/\/ Latest network info\n) on DeviceId\n| extend IPAddresses = iff(isempty(IPAddresses) or isnull(IPAddresses), tostring(pack_array(pack_dictionary(\"IPAddress\", PublicIP, \"PrefixSize\", \"0\", \"AddressSpace\", \"Public\"))), IPAddresses)\n| extend ConnectedNetworks = iff(isempty(ConnectedNetworks) or isnull(ConnectedNetworks), '[]', ConnectedNetworks)\n| mv-apply IPAddressesParsed = parse_json(IPAddresses) on (\n    extend IPAddress = tostring(IPAddressesParsed.IPAddress)\n    | summarize IPsSeen = make_set(IPAddress) by DeviceId, NonOnboardedName = DeviceName, OSPlatform, tostring(SeenBy), ConnectedNetworks, Timestamp\n)\n| mv-apply ConnectedNetworksParsed = parse_json(ConnectedNetworks) on (\n    extend Name = tostring(ConnectedNetworksParsed.Name),\n           Category = tostring(ConnectedNetworksParsed.Category)\n    | summarize NetworkNames = make_set(Name),\n                NetworkCategories = make_set(Category) by DeviceId, NonOnboardedName, OSPlatform, tostring(SeenBy), tostring(IPsSeen), Timestamp\n)\n| summarize \n    IPsSeen = make_set(IPsSeen),\n    DetectingDevices = make_set(SeenBy),         \/\/ Onboarded devices that saw it\n    NetworkNames = make_set(NetworkNames),      \n    NetworkCategories = make_set(NetworkCategories),  \n    LastSeen = max(Timestamp),\n    FirstSeen = min(Timestamp)\n    by NonOnboardedName, OSPlatform, DeviceId\n| where array_length(DetectingDevices) > 0          \/\/ Remove devices with no detecting devices\n| project-reorder NonOnboardedName, IPsSeen, DetectingDevices, NetworkNames, NetworkCategories, OSPlatform, LastSeen, FirstSeen\n| order by LastSeen desc<\/code><\/pre>\n","protected":false},"excerpt":{"rendered":"<p>Cleaner Version<\/p>\n","protected":false},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[1],"tags":[],"class_list":["post-9398","post","type-post","status-publish","format-standard","hentry","category-research"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 4.9.9 - aioseo.com -->\n\t<meta name=\"description\" content=\"\/\/ Non-onboarded\/discovered devices + who saw them + network details + IPs DeviceInfo | where Timestamp &gt; ago(30d) | where OnboardingStatus != &quot;Onboarded&quot; \/\/ all not onboarded\/discovered | where isempty(MergedToDeviceId) \/\/ Remove invalidated\/merged devices | summarize arg_max(Timestamp, *) by DeviceId | invoke SeenBy() \/\/ Add detecting onboarded devices | join kind=leftouter ( DeviceNetworkInfo | where\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"paris\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender\" \/>\n\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 4.9.9\" \/>\n\t\t<meta property=\"og:locale\" content=\"en_US\" \/>\n\t\t<meta property=\"og:site_name\" content=\"Welcome to Pariswells.com |\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender | Welcome to Pariswells.com\" \/>\n\t\t<meta property=\"og:description\" content=\"\/\/ Non-onboarded\/discovered devices + who saw them + network details + IPs DeviceInfo | where Timestamp &gt; ago(30d) | where OnboardingStatus != &quot;Onboarded&quot; \/\/ all not onboarded\/discovered | where isempty(MergedToDeviceId) \/\/ Remove invalidated\/merged devices | summarize arg_max(Timestamp, *) by DeviceId | invoke SeenBy() \/\/ Add detecting onboarded devices | join kind=leftouter ( DeviceNetworkInfo | where\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2025-12-03T22:44:23+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2025-12-03T23:23:45+00:00\" \/>\n\t\t<meta name=\"twitter:card\" content=\"summary\" \/>\n\t\t<meta name=\"twitter:title\" content=\"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender | Welcome to Pariswells.com\" \/>\n\t\t<meta name=\"twitter:description\" content=\"\/\/ Non-onboarded\/discovered devices + who saw them + network details + IPs DeviceInfo | where Timestamp &gt; ago(30d) | where OnboardingStatus != &quot;Onboarded&quot; \/\/ all not onboarded\/discovered | where isempty(MergedToDeviceId) \/\/ Remove invalidated\/merged devices | summarize arg_max(Timestamp, *) by DeviceId | invoke SeenBy() \/\/ Add detecting onboarded devices | join kind=leftouter ( DeviceNetworkInfo | where\" \/>\n\t\t<script type=\"application\/ld+json\" class=\"aioseo-schema\">\n\t\t\t{\"@context\":\"https:\\\/\\\/schema.org\",\"@graph\":[{\"@type\":\"Article\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#article\",\"name\":\"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender | Welcome to Pariswells.com\",\"headline\":\"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender\",\"author\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris#author\"},\"publisher\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#organization\"},\"datePublished\":\"2025-12-03T22:44:23+00:00\",\"dateModified\":\"2025-12-03T23:23:45+00:00\",\"inLanguage\":\"en-US\",\"mainEntityOfPage\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#webpage\"},\"isPartOf\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#webpage\"},\"articleSection\":\"Research\"},{\"@type\":\"BreadcrumbList\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#breadcrumblist\",\"itemListElement\":[{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog#listItem\",\"position\":1,\"name\":\"Home\",\"item\":\"https:\\\/\\\/pariswells.com\\\/blog\",\"nextItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/category\\\/research#listItem\",\"name\":\"Research\"}},{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/category\\\/research#listItem\",\"position\":2,\"name\":\"Research\",\"item\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/category\\\/research\",\"nextItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#listItem\",\"name\":\"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender\"},\"previousItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog#listItem\",\"name\":\"Home\"}},{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#listItem\",\"position\":3,\"name\":\"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender\",\"previousItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/category\\\/research#listItem\",\"name\":\"Research\"}}]},{\"@type\":\"Organization\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#organization\",\"name\":\"Welcome to Pariswells.com\",\"url\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/\"},{\"@type\":\"Person\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris#author\",\"url\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris\",\"name\":\"paris\",\"image\":{\"@type\":\"ImageObject\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#authorImage\",\"url\":\"https:\\\/\\\/secure.gravatar.com\\\/avatar\\\/93b8ee3f592ac401167f870452bd82d43de80152cd3524e2853403658ada9984?s=96&d=mm&r=g\",\"width\":96,\"height\":96,\"caption\":\"paris\"}},{\"@type\":\"WebPage\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#webpage\",\"url\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender\",\"name\":\"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender | Welcome to Pariswells.com\",\"description\":\"\\\/\\\/ Non-onboarded\\\/discovered devices + who saw them + network details + IPs DeviceInfo | where Timestamp > ago(30d) | where OnboardingStatus != \\\"Onboarded\\\" \\\/\\\/ all not onboarded\\\/discovered | where isempty(MergedToDeviceId) \\\/\\\/ Remove invalidated\\\/merged devices | summarize arg_max(Timestamp, *) by DeviceId | invoke SeenBy() \\\/\\\/ Add detecting onboarded devices | join kind=leftouter ( DeviceNetworkInfo | where\",\"inLanguage\":\"en-US\",\"isPartOf\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#website\"},\"breadcrumb\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#breadcrumblist\"},\"author\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris#author\"},\"creator\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris#author\"},\"datePublished\":\"2025-12-03T22:44:23+00:00\",\"dateModified\":\"2025-12-03T23:23:45+00:00\"},{\"@type\":\"WebSite\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#website\",\"url\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/\",\"name\":\"Welcome to Pariswells.com\",\"inLanguage\":\"en-US\",\"publisher\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#organization\"}}]}\n\t\t<\/script>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender | Welcome to Pariswells.com","description":"\/\/ Non-onboarded\/discovered devices + who saw them + network details + IPs DeviceInfo | where Timestamp > ago(30d) | where OnboardingStatus != \"Onboarded\" \/\/ all not onboarded\/discovered | where isempty(MergedToDeviceId) \/\/ Remove invalidated\/merged devices | summarize arg_max(Timestamp, *) by DeviceId | invoke SeenBy() \/\/ Add detecting onboarded devices | join kind=leftouter ( DeviceNetworkInfo | where","canonical_url":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":{"@context":"https:\/\/schema.org","@graph":[{"@type":"Article","@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#article","name":"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender | Welcome to Pariswells.com","headline":"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender","author":{"@id":"https:\/\/pariswells.com\/blog\/author\/paris#author"},"publisher":{"@id":"https:\/\/pariswells.com\/blog\/#organization"},"datePublished":"2025-12-03T22:44:23+00:00","dateModified":"2025-12-03T23:23:45+00:00","inLanguage":"en-US","mainEntityOfPage":{"@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#webpage"},"isPartOf":{"@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#webpage"},"articleSection":"Research"},{"@type":"BreadcrumbList","@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog#listItem","position":1,"name":"Home","item":"https:\/\/pariswells.com\/blog","nextItem":{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/category\/research#listItem","name":"Research"}},{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/category\/research#listItem","position":2,"name":"Research","item":"https:\/\/pariswells.com\/blog\/category\/research","nextItem":{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#listItem","name":"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender"},"previousItem":{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog#listItem","name":"Home"}},{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#listItem","position":3,"name":"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender","previousItem":{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/category\/research#listItem","name":"Research"}}]},{"@type":"Organization","@id":"https:\/\/pariswells.com\/blog\/#organization","name":"Welcome to Pariswells.com","url":"https:\/\/pariswells.com\/blog\/"},{"@type":"Person","@id":"https:\/\/pariswells.com\/blog\/author\/paris#author","url":"https:\/\/pariswells.com\/blog\/author\/paris","name":"paris","image":{"@type":"ImageObject","@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#authorImage","url":"https:\/\/secure.gravatar.com\/avatar\/93b8ee3f592ac401167f870452bd82d43de80152cd3524e2853403658ada9984?s=96&d=mm&r=g","width":96,"height":96,"caption":"paris"}},{"@type":"WebPage","@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#webpage","url":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender","name":"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender | Welcome to Pariswells.com","description":"\/\/ Non-onboarded\/discovered devices + who saw them + network details + IPs DeviceInfo | where Timestamp > ago(30d) | where OnboardingStatus != \"Onboarded\" \/\/ all not onboarded\/discovered | where isempty(MergedToDeviceId) \/\/ Remove invalidated\/merged devices | summarize arg_max(Timestamp, *) by DeviceId | invoke SeenBy() \/\/ Add detecting onboarded devices | join kind=leftouter ( DeviceNetworkInfo | where","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/pariswells.com\/blog\/#website"},"breadcrumb":{"@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender#breadcrumblist"},"author":{"@id":"https:\/\/pariswells.com\/blog\/author\/paris#author"},"creator":{"@id":"https:\/\/pariswells.com\/blog\/author\/paris#author"},"datePublished":"2025-12-03T22:44:23+00:00","dateModified":"2025-12-03T23:23:45+00:00"},{"@type":"WebSite","@id":"https:\/\/pariswells.com\/blog\/#website","url":"https:\/\/pariswells.com\/blog\/","name":"Welcome to Pariswells.com","inLanguage":"en-US","publisher":{"@id":"https:\/\/pariswells.com\/blog\/#organization"}}]},"og:locale":"en_US","og:site_name":"Welcome to Pariswells.com |","og:type":"article","og:title":"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender | Welcome to Pariswells.com","og:description":"\/\/ Non-onboarded\/discovered devices + who saw them + network details + IPs DeviceInfo | where Timestamp &gt; ago(30d) | where OnboardingStatus != &quot;Onboarded&quot; \/\/ all not onboarded\/discovered | where isempty(MergedToDeviceId) \/\/ Remove invalidated\/merged devices | summarize arg_max(Timestamp, *) by DeviceId | invoke SeenBy() \/\/ Add detecting onboarded devices | join kind=leftouter ( DeviceNetworkInfo | where","og:url":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender","article:published_time":"2025-12-03T22:44:23+00:00","article:modified_time":"2025-12-03T23:23:45+00:00","twitter:card":"summary","twitter:title":"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender | Welcome to Pariswells.com","twitter:description":"\/\/ Non-onboarded\/discovered devices + who saw them + network details + IPs DeviceInfo | where Timestamp &gt; ago(30d) | where OnboardingStatus != &quot;Onboarded&quot; \/\/ all not onboarded\/discovered | where isempty(MergedToDeviceId) \/\/ Remove invalidated\/merged devices | summarize arg_max(Timestamp, *) by DeviceId | invoke SeenBy() \/\/ Add detecting onboarded devices | join kind=leftouter ( DeviceNetworkInfo | where"},"aioseo_meta_data":{"post_id":"9398","title":null,"description":null,"keywords":null,"keyphrases":null,"canonical_url":null,"og_title":null,"og_description":null,"og_object_type":"default","og_image_type":"default","og_image_url":null,"og_image_width":null,"og_image_height":null,"og_image_custom_url":null,"og_image_custom_fields":null,"og_video":null,"og_custom_url":null,"og_article_section":null,"og_article_tags":null,"twitter_use_og":false,"twitter_card":"default","twitter_image_type":"default","twitter_image_url":null,"twitter_image_custom_url":null,"twitter_image_custom_fields":null,"twitter_title":null,"twitter_description":null,"schema":{"blockGraphs":[],"customGraphs":[],"default":{"data":{"Article":[],"Course":[],"Dataset":[],"FAQPage":[],"Movie":[],"Person":[],"Product":[],"ProductReview":[],"Car":[],"Recipe":[],"Service":[],"SoftwareApplication":[],"WebPage":[]},"graphName":"Article","isEnabled":true},"graphs":[]},"schema_type":"default","schema_type_options":null,"pillar_content":false,"robots_default":true,"robots_noindex":false,"robots_noarchive":false,"robots_nosnippet":false,"robots_nofollow":false,"robots_noimageindex":false,"robots_noodp":false,"robots_notranslate":false,"robots_max_snippet":null,"robots_max_videopreview":null,"robots_max_imagepreview":"large","priority":null,"frequency":null,"location":null,"local_seo":null,"breadcrumb_settings":null,"limit_modified_date":false,"ai":null,"created":"2025-12-09 21:38:10","updated":"2025-12-09 21:38:10","primary_term":null,"seo_analyzer_scan_date":null},"aioseo_breadcrumb":"<div class=\"aioseo-breadcrumbs\"><span class=\"aioseo-breadcrumb\">\n\t\t\t<a href=\"https:\/\/pariswells.com\/blog\" title=\"Home\">Home<\/a>\n\t\t<\/span><span class=\"aioseo-breadcrumb-separator\">&raquo;<\/span><span class=\"aioseo-breadcrumb\">\n\t\t\t<a href=\"https:\/\/pariswells.com\/blog\/category\/research\" title=\"Research\">Research<\/a>\n\t\t<\/span><span class=\"aioseo-breadcrumb-separator\">&raquo;<\/span><span class=\"aioseo-breadcrumb\">\n\t\t\tAdvanced Hunting to Find all Devices not onboarded and discovered Devices to Defender\n\t\t<\/span><\/div>","aioseo_breadcrumb_json":[{"label":"Home","link":"https:\/\/pariswells.com\/blog"},{"label":"Research","link":"https:\/\/pariswells.com\/blog\/category\/research"},{"label":"Advanced Hunting to Find all Devices not onboarded and discovered Devices to Defender","link":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-all-devices-not-onboarded-and-discovered-devices-to-defender"}],"_links":{"self":[{"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/posts\/9398","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/comments?post=9398"}],"version-history":[{"count":2,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/posts\/9398\/revisions"}],"predecessor-version":[{"id":9401,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/posts\/9398\/revisions\/9401"}],"wp:attachment":[{"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/media?parent=9398"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/categories?post=9398"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/tags?post=9398"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}