{"id":8128,"date":"2024-07-18T01:46:03","date_gmt":"2024-07-18T01:46:03","guid":{"rendered":"https:\/\/pariswells.com\/blog\/?p=8128"},"modified":"2024-07-18T01:46:05","modified_gmt":"2024-07-18T01:46:05","slug":"advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender","status":"publish","type":"post","link":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender","title":{"rendered":"Advanced Hunting to Find Word and Excel Macros in Environment with Defender"},"content":{"rendered":"\n<pre class=\"wp-block-code\"><code class=\"\">\/\/Summarize macro usage on your devies by creating a list all macros used, a count of how many users are using each one and the account names\n\n\/\/Data connector required for this query - M365 Defender - Device* tables\n\n\/\/Macro usage may be double counted if the same file is executed from two locations, i.e from a network share and a local drive.\n\/\/Microsoft Sentinel query\nunion DeviceFileEvents, DeviceNetworkEvents\n| where TimeGenerated > ago(30d)\n| project InitiatingProcessCommandLine, InitiatingProcessAccountName\n| where InitiatingProcessCommandLine startswith '\"EXCEL.EXE'  \n| where InitiatingProcessCommandLine endswith '.xltm\"' or InitiatingProcessCommandLine endswith '.xlsm\"'\n\/\/Retrieve distinct values for process, hash and account\n| distinct InitiatingProcessCommandLine, InitiatingProcessAccountName\n\/\/Parse the file path and file name from the process\n| parse-where InitiatingProcessCommandLine with * '\"EXCEL.EXE\" \"' ['Macro Filename'] '\"' *\n\/\/Summarize the list of macro files by which users have used them\n| summarize ['List of Users']=make_set(InitiatingProcessAccountName), ['Count of Users']=dcount(InitiatingProcessAccountName) by ['Macro Filename']\n| sort by ['Count of Users'] desc \n\n\/\/Advanced Hunting query\n\n\/\/Data connector required for this query - Advanced Hunting license\n\nunion DeviceFileEvents, DeviceNetworkEvents\n| where Timestamp > ago(30d)\n| project InitiatingProcessCommandLine, InitiatingProcessAccountName\n| where InitiatingProcessCommandLine startswith '\"EXCEL.EXE'  \n| where InitiatingProcessCommandLine endswith '.xltm\"' or InitiatingProcessCommandLine endswith '.xlsm\"'\n\/\/Retrieve distinct values for process, hash and account\n| distinct InitiatingProcessCommandLine, InitiatingProcessAccountName\n\/\/Parse the file path and file name from the process\n| parse-where InitiatingProcessCommandLine with * '\"EXCEL.EXE\" \"' ['Macro Filename'] '\"' *\n\/\/Summarize the list of macro files by which users have used them\n| summarize ['List of Users']=make_set(InitiatingProcessAccountName), ['Count of Users']=dcount(InitiatingProcessAccountName) by ['Macro Filename']\n| sort by ['Count of Users'] desc <\/code><\/pre>\n\n\n\n<pre class=\"wp-block-code\"><code class=\"\">\/\/Detect when an Excel macro connects to the internet. \n\/\/Some IPs returned shown may be Microsoft telemetry but these events are still worth investigating.\n\n\/\/Data connector required for this query - M365 Defender - Device* tables\n\n\/\/Microsoft Sentinel query\nDeviceNetworkEvents\n| where InitiatingProcessFileName contains \"excel.exe\"\n| where InitiatingProcessCommandLine contains \".xlsm\" or InitiatingProcessCommandLine contains \".xltm\"\n\/\/Exclude Microsoft telemetry endpoints \n| where RemoteUrl !endswith \"outlook.com\" \n    and RemoteUrl !endswith \"office.com\"\n    and RemoteUrl !endswith \"microsoft.com\"\n    and RemoteUrl !endswith \"office365.com\"\n    and RemoteUrl !endswith \"live.com\"\n    and RemoteUrl !endswith \"office.net\"\n| where RemoteIPType == \"Public\"\n| project\n    TimeGenerated,\n    DeviceName,\n    InitiatingProcessCommandLine,\n    LocalIP,\n    RemoteIP,\n    RemotePort,\n    RemoteUrl\n\n\/\/Advanced Hunting query\n\n\/\/Data connector required for this query - Advanced Hunting license\n\nDeviceNetworkEvents\n| where InitiatingProcessFileName contains \"excel.exe\"\n| where InitiatingProcessCommandLine contains \".xlsm\" or InitiatingProcessCommandLine contains \".xltm\"\n| where RemoteIPType == \"Public\"\n\/\/Exclude Microsoft telemetry endpoints \n| where RemoteUrl !endswith \"outlook.com\" \n    and RemoteUrl !endswith \"office.com\"\n    and RemoteUrl !endswith \"microsoft.com\"\n    and RemoteUrl !endswith \"office365.com\"\n    and RemoteUrl !endswith \"live.com\"\n    and RemoteUrl !endswith \"office.net\"\n| project\n    Timestamp,\n    DeviceName,\n    InitiatingProcessCommandLine,\n    LocalIP,\n    RemoteIP,\n    RemotePort,\n    RemoteUrl<\/code><\/pre>\n\n\n\n<pre class=\"wp-block-code\"><code class=\"\">\/\/\"Now we know that every time a user clicks on 'Enable Editing; or 'Enable \/\/Content', Microsoft Office will add the path to the document as a Registry \/\/value under the program's TrustRecords key.\n\nDeviceRegistryEvents\n| where RegistryKey has @\"SOFTWARE\\Microsoft\\Office\\16.0\\Excel\\Security\\Trusted Documents\\TrustRecords\"\n| where RegistryValueName has \"xlsm\"\n| project Timestamp, DeviceName, RegistryValueName\n\nDeviceRegistryEvents\n| where RegistryKey has @\"SOFTWARE\\Microsoft\\Office\\16.0\\Word\\Security\\Trusted Documents\\TrustRecords\"\n| where RegistryValueName has \"docm\"\n| project Timestamp, DeviceName, RegistryValueName<\/code><\/pre>\n","protected":false},"excerpt":{"rendered":"","protected":false},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[1],"tags":[],"class_list":["post-8128","post","type-post","status-publish","format-standard","hentry","category-research"],"aioseo_notices":[],"aioseo_head":"\n\t\t<!-- All in One SEO 4.9.8 - aioseo.com -->\n\t<meta name=\"description\" content=\"\/\/Summarize macro usage on your devies by creating a list all macros used, a count of how many users are using each one and the account names \/\/Data connector required for this query - M365 Defender - Device* tables \/\/Macro usage may be double counted if the same file is executed from two locations, i.e\" \/>\n\t<meta name=\"robots\" content=\"max-image-preview:large\" \/>\n\t<meta name=\"author\" content=\"paris\"\/>\n\t<link rel=\"canonical\" href=\"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender\" \/>\n\t<meta name=\"generator\" content=\"All in One SEO (AIOSEO) 4.9.8\" \/>\n\t\t<meta property=\"og:locale\" content=\"en_US\" \/>\n\t\t<meta property=\"og:site_name\" content=\"Welcome to Pariswells.com |\" \/>\n\t\t<meta property=\"og:type\" content=\"article\" \/>\n\t\t<meta property=\"og:title\" content=\"Advanced Hunting to Find Word and Excel Macros in Environment with Defender | Welcome to Pariswells.com\" \/>\n\t\t<meta property=\"og:description\" content=\"\/\/Summarize macro usage on your devies by creating a list all macros used, a count of how many users are using each one and the account names \/\/Data connector required for this query - M365 Defender - Device* tables \/\/Macro usage may be double counted if the same file is executed from two locations, i.e\" \/>\n\t\t<meta property=\"og:url\" content=\"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender\" \/>\n\t\t<meta property=\"article:published_time\" content=\"2024-07-18T01:46:03+00:00\" \/>\n\t\t<meta property=\"article:modified_time\" content=\"2024-07-18T01:46:05+00:00\" \/>\n\t\t<meta name=\"twitter:card\" content=\"summary\" \/>\n\t\t<meta name=\"twitter:title\" content=\"Advanced Hunting to Find Word and Excel Macros in Environment with Defender | Welcome to Pariswells.com\" \/>\n\t\t<meta name=\"twitter:description\" content=\"\/\/Summarize macro usage on your devies by creating a list all macros used, a count of how many users are using each one and the account names \/\/Data connector required for this query - M365 Defender - Device* tables \/\/Macro usage may be double counted if the same file is executed from two locations, i.e\" \/>\n\t\t<script type=\"application\/ld+json\" class=\"aioseo-schema\">\n\t\t\t{\"@context\":\"https:\\\/\\\/schema.org\",\"@graph\":[{\"@type\":\"Article\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#article\",\"name\":\"Advanced Hunting to Find Word and Excel Macros in Environment with Defender | Welcome to Pariswells.com\",\"headline\":\"Advanced Hunting to Find Word and Excel Macros in Environment with Defender\",\"author\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris#author\"},\"publisher\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#organization\"},\"datePublished\":\"2024-07-18T01:46:03+00:00\",\"dateModified\":\"2024-07-18T01:46:05+00:00\",\"inLanguage\":\"en-US\",\"mainEntityOfPage\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#webpage\"},\"isPartOf\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#webpage\"},\"articleSection\":\"Research\"},{\"@type\":\"BreadcrumbList\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#breadcrumblist\",\"itemListElement\":[{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog#listItem\",\"position\":1,\"name\":\"Home\",\"item\":\"https:\\\/\\\/pariswells.com\\\/blog\",\"nextItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/category\\\/research#listItem\",\"name\":\"Research\"}},{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/category\\\/research#listItem\",\"position\":2,\"name\":\"Research\",\"item\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/category\\\/research\",\"nextItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#listItem\",\"name\":\"Advanced Hunting to Find Word and Excel Macros in Environment with Defender\"},\"previousItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog#listItem\",\"name\":\"Home\"}},{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#listItem\",\"position\":3,\"name\":\"Advanced Hunting to Find Word and Excel Macros in Environment with Defender\",\"previousItem\":{\"@type\":\"ListItem\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/category\\\/research#listItem\",\"name\":\"Research\"}}]},{\"@type\":\"Organization\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#organization\",\"name\":\"Welcome to Pariswells.com\",\"url\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/\"},{\"@type\":\"Person\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris#author\",\"url\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris\",\"name\":\"paris\",\"image\":{\"@type\":\"ImageObject\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#authorImage\",\"url\":\"https:\\\/\\\/secure.gravatar.com\\\/avatar\\\/93b8ee3f592ac401167f870452bd82d43de80152cd3524e2853403658ada9984?s=96&d=mm&r=g\",\"width\":96,\"height\":96,\"caption\":\"paris\"}},{\"@type\":\"WebPage\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#webpage\",\"url\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender\",\"name\":\"Advanced Hunting to Find Word and Excel Macros in Environment with Defender | Welcome to Pariswells.com\",\"description\":\"\\\/\\\/Summarize macro usage on your devies by creating a list all macros used, a count of how many users are using each one and the account names \\\/\\\/Data connector required for this query - M365 Defender - Device* tables \\\/\\\/Macro usage may be double counted if the same file is executed from two locations, i.e\",\"inLanguage\":\"en-US\",\"isPartOf\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#website\"},\"breadcrumb\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/research\\\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#breadcrumblist\"},\"author\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris#author\"},\"creator\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/author\\\/paris#author\"},\"datePublished\":\"2024-07-18T01:46:03+00:00\",\"dateModified\":\"2024-07-18T01:46:05+00:00\"},{\"@type\":\"WebSite\",\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#website\",\"url\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/\",\"name\":\"Welcome to Pariswells.com\",\"inLanguage\":\"en-US\",\"publisher\":{\"@id\":\"https:\\\/\\\/pariswells.com\\\/blog\\\/#organization\"}}]}\n\t\t<\/script>\n\t\t<!-- All in One SEO -->\n\n","aioseo_head_json":{"title":"Advanced Hunting to Find Word and Excel Macros in Environment with Defender | Welcome to Pariswells.com","description":"\/\/Summarize macro usage on your devies by creating a list all macros used, a count of how many users are using each one and the account names \/\/Data connector required for this query - M365 Defender - Device* tables \/\/Macro usage may be double counted if the same file is executed from two locations, i.e","canonical_url":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender","robots":"max-image-preview:large","keywords":"","webmasterTools":{"miscellaneous":""},"schema":{"@context":"https:\/\/schema.org","@graph":[{"@type":"Article","@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#article","name":"Advanced Hunting to Find Word and Excel Macros in Environment with Defender | Welcome to Pariswells.com","headline":"Advanced Hunting to Find Word and Excel Macros in Environment with Defender","author":{"@id":"https:\/\/pariswells.com\/blog\/author\/paris#author"},"publisher":{"@id":"https:\/\/pariswells.com\/blog\/#organization"},"datePublished":"2024-07-18T01:46:03+00:00","dateModified":"2024-07-18T01:46:05+00:00","inLanguage":"en-US","mainEntityOfPage":{"@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#webpage"},"isPartOf":{"@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#webpage"},"articleSection":"Research"},{"@type":"BreadcrumbList","@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog#listItem","position":1,"name":"Home","item":"https:\/\/pariswells.com\/blog","nextItem":{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/category\/research#listItem","name":"Research"}},{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/category\/research#listItem","position":2,"name":"Research","item":"https:\/\/pariswells.com\/blog\/category\/research","nextItem":{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#listItem","name":"Advanced Hunting to Find Word and Excel Macros in Environment with Defender"},"previousItem":{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog#listItem","name":"Home"}},{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#listItem","position":3,"name":"Advanced Hunting to Find Word and Excel Macros in Environment with Defender","previousItem":{"@type":"ListItem","@id":"https:\/\/pariswells.com\/blog\/category\/research#listItem","name":"Research"}}]},{"@type":"Organization","@id":"https:\/\/pariswells.com\/blog\/#organization","name":"Welcome to Pariswells.com","url":"https:\/\/pariswells.com\/blog\/"},{"@type":"Person","@id":"https:\/\/pariswells.com\/blog\/author\/paris#author","url":"https:\/\/pariswells.com\/blog\/author\/paris","name":"paris","image":{"@type":"ImageObject","@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#authorImage","url":"https:\/\/secure.gravatar.com\/avatar\/93b8ee3f592ac401167f870452bd82d43de80152cd3524e2853403658ada9984?s=96&d=mm&r=g","width":96,"height":96,"caption":"paris"}},{"@type":"WebPage","@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#webpage","url":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender","name":"Advanced Hunting to Find Word and Excel Macros in Environment with Defender | Welcome to Pariswells.com","description":"\/\/Summarize macro usage on your devies by creating a list all macros used, a count of how many users are using each one and the account names \/\/Data connector required for this query - M365 Defender - Device* tables \/\/Macro usage may be double counted if the same file is executed from two locations, i.e","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/pariswells.com\/blog\/#website"},"breadcrumb":{"@id":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender#breadcrumblist"},"author":{"@id":"https:\/\/pariswells.com\/blog\/author\/paris#author"},"creator":{"@id":"https:\/\/pariswells.com\/blog\/author\/paris#author"},"datePublished":"2024-07-18T01:46:03+00:00","dateModified":"2024-07-18T01:46:05+00:00"},{"@type":"WebSite","@id":"https:\/\/pariswells.com\/blog\/#website","url":"https:\/\/pariswells.com\/blog\/","name":"Welcome to Pariswells.com","inLanguage":"en-US","publisher":{"@id":"https:\/\/pariswells.com\/blog\/#organization"}}]},"og:locale":"en_US","og:site_name":"Welcome to Pariswells.com |","og:type":"article","og:title":"Advanced Hunting to Find Word and Excel Macros in Environment with Defender | Welcome to Pariswells.com","og:description":"\/\/Summarize macro usage on your devies by creating a list all macros used, a count of how many users are using each one and the account names \/\/Data connector required for this query - M365 Defender - Device* tables \/\/Macro usage may be double counted if the same file is executed from two locations, i.e","og:url":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender","article:published_time":"2024-07-18T01:46:03+00:00","article:modified_time":"2024-07-18T01:46:05+00:00","twitter:card":"summary","twitter:title":"Advanced Hunting to Find Word and Excel Macros in Environment with Defender | Welcome to Pariswells.com","twitter:description":"\/\/Summarize macro usage on your devies by creating a list all macros used, a count of how many users are using each one and the account names \/\/Data connector required for this query - M365 Defender - Device* tables \/\/Macro usage may be double counted if the same file is executed from two locations, i.e"},"aioseo_meta_data":{"post_id":"8128","title":null,"description":null,"keywords":null,"keyphrases":{"focus":{"keyphrase":"","score":0,"analysis":{"keyphraseInTitle":{"score":0,"maxScore":9,"error":1}}},"additional":[]},"canonical_url":null,"og_title":null,"og_description":null,"og_object_type":"default","og_image_type":"default","og_image_url":null,"og_image_width":null,"og_image_height":null,"og_image_custom_url":null,"og_image_custom_fields":null,"og_video":"","og_custom_url":null,"og_article_section":null,"og_article_tags":null,"twitter_use_og":false,"twitter_card":"default","twitter_image_type":"default","twitter_image_url":null,"twitter_image_custom_url":null,"twitter_image_custom_fields":null,"twitter_title":null,"twitter_description":null,"schema":{"blockGraphs":[],"customGraphs":[],"default":{"data":{"Article":[],"Course":[],"Dataset":[],"FAQPage":[],"Movie":[],"Person":[],"Product":[],"ProductReview":[],"Car":[],"Recipe":[],"Service":[],"SoftwareApplication":[],"WebPage":[]},"graphName":"Article","isEnabled":true},"graphs":[]},"schema_type":"default","schema_type_options":null,"pillar_content":false,"robots_default":true,"robots_noindex":false,"robots_noarchive":false,"robots_nosnippet":false,"robots_nofollow":false,"robots_noimageindex":false,"robots_noodp":false,"robots_notranslate":false,"robots_max_snippet":"-1","robots_max_videopreview":"-1","robots_max_imagepreview":"large","priority":null,"frequency":"default","location":null,"local_seo":null,"breadcrumb_settings":null,"limit_modified_date":false,"ai":null,"created":"2024-07-18 01:37:49","updated":"2024-07-18 01:59:08","primary_term":null,"seo_analyzer_scan_date":null},"aioseo_breadcrumb":"<div class=\"aioseo-breadcrumbs\"><span class=\"aioseo-breadcrumb\">\n\t\t\t<a href=\"https:\/\/pariswells.com\/blog\" title=\"Home\">Home<\/a>\n\t\t<\/span><span class=\"aioseo-breadcrumb-separator\">&raquo;<\/span><span class=\"aioseo-breadcrumb\">\n\t\t\t<a href=\"https:\/\/pariswells.com\/blog\/category\/research\" title=\"Research\">Research<\/a>\n\t\t<\/span><span class=\"aioseo-breadcrumb-separator\">&raquo;<\/span><span class=\"aioseo-breadcrumb\">\n\t\t\tAdvanced Hunting to Find Word and Excel Macros in Environment with Defender\n\t\t<\/span><\/div>","aioseo_breadcrumb_json":[{"label":"Home","link":"https:\/\/pariswells.com\/blog"},{"label":"Research","link":"https:\/\/pariswells.com\/blog\/category\/research"},{"label":"Advanced Hunting to Find Word and Excel Macros in Environment with Defender","link":"https:\/\/pariswells.com\/blog\/research\/advanced-hunting-to-find-word-and-excel-macros-in-environment-with-defender"}],"_links":{"self":[{"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/posts\/8128","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/comments?post=8128"}],"version-history":[{"count":1,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/posts\/8128\/revisions"}],"predecessor-version":[{"id":8129,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/posts\/8128\/revisions\/8129"}],"wp:attachment":[{"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/media?parent=8128"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/categories?post=8128"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/pariswells.com\/blog\/wp-json\/wp\/v2\/tags?post=8128"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}