Posts Tagged ‘stack’

Get Model Number and Serial for Firmware

Login to your switch via SSH and run 

show switch

This will show you the System Type ( Model of the switch ) and if its stacked, now type 

show version

This will show you your current firmware and Also Serial Number ( In Red ) 

Download Firmware

1. Go to Extremenetwork Support and Click Downloads for ExtremeXOS for your switch model
2. Login using your account. You have to register if you don’t have account.
3. Click Accept All.
4. Type the serial number.
5. Click Software Downloads.
6. Click the correct ExtremeXOS image and download to your tftp server.

Setup TFTP

Free tftp tools such as tftp32 will work for the switch upgrade

Make sure Port UDP 69 is allowed through Windows Firewall

Even if your windows Firewall is disabled , make sure its disabled on Guest Networks as this will usually be the network the management speaks on not domain

Make sure the machine you are using does not have WDS enabled , WDS uses TFTP 

Run TFTP and make sure the server is listening on an Network IP ( NOT 172.0.0.1 )

Copy the .xos file to the TFTP Directory 

In SSH make sure you can Ping the IP of the TFTP server from the Switch via

ping %IP OF TFTPServer% 

And you get a reply 

Backup Existing Config

upload config %IP OF TFTPServer% config.xsf VR-Default

Download and install new Image

download image %IP OF TFTPServer%  summitX-22.3.1.4-patch1-8.xos “VR-Default” secondary\

Do you want to install image after downloading? (y – yes, n – no, – cancel) Yes

You will need to reboot the switch and if the switch is in a stack you will need to reboot them both as Stack switches cannot be in different versions

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)

Switch-A(config)#interface port-channel 1
Switch-A(config-if)#switchport trunk encapsulation dot1q
Switch-A(config-if)#switchport mode trunk
Switch-A(config-if)#speed nonegotiate

Switch-A(config)#interface GigabitEthernet1/1/1
Switch-A(config-if)#switchport mode trunk
Switch-A(config-if)#speed nonegotiate
Switch-A(config-if)#channel-group 1 mode active

Switch-A(config)#interface GigabitEthernet2/1/1
Switch-A(config-if)#switchport mode trunk
Switch-A(config-if)#speed nonegotiate
Switch-A(config-if)#channel-group 1 mode active
——————————————————-

Switch-B(config)#interface port-channel 1
Switch-B(config-if)#switchport trunk encapsulation dot1q
Switch-B(config-if)#switchport mode trunk
Switch-B(config-if)#speed nonegotiate

Switch-B(config)#interface GigabitEthernet1/1/1
Switch-B(config-if)#switchport mode trunk
Switch-B(config-if)#speed nonegotiate
Switch-B(config-if)#channel-group 1 mode active

Switch-B(config)#interface GigabitEthernet2/1/1
Switch-B(config-if)#switchport mode trunk
Switch-B(config-if)#speed nonegotiate
Switch-B(config-if)#channel-group 1 mode active

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)

Find the latest Firmware : https://software.cisco.com/download/release.html?mdfid=284846029&softwareid=282046477&release=3.3.0SE&flowid=45549

Setup TFTP Server ( Download : http://tftpd32.jounin.net/tftpd32_download.html )

Copy Bin file to TFTP Directory

3650-SW1#copy tftp flash

3650-SW1#Address or name of remote host []? 10.1.1.250
3650-SW1#Source filename []? cat3k_caa-universalk9.SPA.03.06.06.E.152-2.E6.bin
3650-SW1#Destination filename [cat3k_caa-universalk9.SPA.03.03.01.SE.150-1.EZ1.bin]?<enter>

3850-SW1#software install file flash:cat3k_caa-universalk9.SPA.03.06.06.E.152-2.E6.bin switch 1-4

The install should ask you to reload which will restart the whole stack ( All Stack members should run the same IOS ) 

If the SSH console disconnects during the install progress you will need to do an Manual Reload Command

VN:F [1.9.22_1171]
Rating: 0.0/10 (0 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)